flownative/gravatar

Last activity on 12 December 2020
  • 1
  • 3483
composer require flownative/gravatar

Gravatar View Helper for Flow

v2.0.4

Gravatar View Helper for Flow

Version
v2.0.4
Type
neos-package
Release Date
Dec 18, 2020 10:06:05 a.m.
Source
git
Distribution
zip
Requires
  • neos/flow: ^4.0 || ^5.0 || ^6.0 || ^7.0 || dev-master
Requires (dev)
None
Suggest
None
Provides
None
Conflicts
None
Replaces
None
MIT 5a00fe3da65674ba783950c8639d12ecbd9db74e

MIT license Packagist Maintenance level: Love

Gravatar View Helper for Flow

This package provides a Fluid View Helper which can be used in Neos Flow based applications for displaying Gravatar images.

Installation

The Flownative Gravatar package is installed as a regular Flow package via Composer. For your existing project, simply include flownative/gravatar into the dependencies of your Flow or Neos distribution:

    $ composer require flownative/gravatar:~2.0

Usage

In your Fluid template, use the Gravatar View Helper like any other view helper. Possible arguments for the view helper are:

Argument Required ? Description
email yes specifies the email address of the Gravatar to display
size no the size in pixels (used for width and height)
default no a URL pointing to a fallback image if no Gravatar exists for the given email address. Instead of a URL, the "default" parameter can also be one of "404", "mm", "identicon", "monsterid", "wavatar", retro" or "blank"
{namespace gravatar=Flownative\Gravatar\ViewHelpers}
<html lang="en">
...
    <body>
        <gravatar:gravatar email="{someEmailAddress}" default="retro" size="48" alt="image" class="img-circle" width="48" height="48" />
    </body>
</html>
The content of the readme is provided by Github
The same vendor provides 39 package(s).