codeq/csp-report-endpoint

Last activity on 4 April 2021
  • 609
composer require codeq/csp-report-endpoint

Provides an endpoint for logging CSP violations.

1.0.0

Provides an endpoint for logging CSP violations.

Version
1.0.0
Type
neos-package
Release Date
16.04.2021 17:13:09
Source
git
Distribution
zip
Requires
Requires (dev)
None
Suggest
None
Provides
None
Conflicts
None
Replaces
None
MIT f3a04ef919557a7abb77cd7de3f2ad69da07d0e8

Flow Consent Security Policy (CSP) Violation Report Endpoint

This package adds an endpoint to the Flow framework to log content security policy (CSP) violations. It simply logs every request that is sent to the endpoint in the defined format.

Usage

To use this endpoint, extend your Content-Security-Policy header to contain report-uri /csp-violation-report/.

Maintainers

Felix Gradinaru, CodeQ Web Factory

License

This package is distributed under the MIT license.

The content of the readme is provided by Github
The same vendor provides 19 package(s).